The guiding rule.

Exchange server 2013+ and Outlook version 2013+ support Microsoft Office Add-ins.

Outlook versions supported:

  • Outlook on the Web

  • Outlook 2013+

  • Outlook 2016+

  • Outlook 2016 for Mac


Hence, if your company has Exchange 2010 and Outlook 2016. Your company will not be able to use Office add-ins from Outlook. Because minimum requirements are Exchange server 2013.

Microsoft resources available:

Outlook add-in deployment

For on-premises and online environments, you can deploy Outlook add-ins via the Office 365 Admin Center or Exchange Admin Center.

Outlook add-in deployment requires:

  • Office 365, Exchange Online, or Exchange Server 2013 or later

  • Outlook 2013 or later

Did this answer your question?